Krups single trigger coffee grinder identified as style F203.

Preguntas 6 Ver todo

How do I remove the blades? (Can't pull them off!)


My grinder is not similar to the ones in the instructions. It's the same model, but it looks different inside. The blades are fasten with something that looks like a plastic nut on top. I´ve tried pulling on the blades, but it doesen´t seem to work. I´ve also tried to undo the nut, my tools are causing damage to the nut.

Do anyone know if this is a nut, or pulling harder is the solution? And if so, do anyone know if it is a right or left threaded nut (normal or lynx)?

My problem with the grinder is that the blades wont turn. The motor is working, but of some reason, either the rotor in the motor or the blade assy is stuck.


Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 5


Thanks for the answer! I got to the motor now, and the upper bearing is seized. As it's clearly cause of rust, this is my own fault. A few times I have used water to clean it, and the gasket on the shaft wasn't enough to stop penetration to the motor.

I guess there is no chance of saving it, but I will play with it some more and see what happens. Do anyone know how to disassemble the motor? I have removed the bolts, but the bearings are holding the upper and lower parts together (shrink fit?)


Agregar un comentario

3 Respuestas

Respuesta Más Útil

The blade is right hand threaded onto the motor shaft. If the motor is running, I can't understand

why the blade is stationary unless the threads are stripped. That would seem unlikely though. If

you are trying to remove the blade by twisting the blade's plastic hub, it probably will break before

the blade is loosened. (Have you have removed the bottom of the grinder to access the slot in the

end of the motor shaft ?) By inserting a screwdriver in the slot you can keep the armature stationary

while you unscrew the blade. Then (with a rag for padding) the blade can be unscrewed (with a bit

of effort). If the armature isn't turning when you are trying to remove the blade (and you haven't

removed the base to access the slot), then the motor is probably frozen. Time to spend $20 on a

new grinder. Also, even if you get it apart, I don't think there are any serviceable parts inside.

Fue útil esta respuesta?

Calificación 2
Agregar un comentario

Very simple: there is a slot through the bottom plate that is hidden under the product label. Take the label off, and the slot will be visible. This is a window that gives you access to the screw at the bottom of the engine shaft. Put a flat screwdriver head in the window and rotate the blades until the screwdriver sits in the slot of the shaft screw. Now keep the shaft steady and rotate the blade to unscrew. No need to take the bottom plate apart. It is a pain in the neck, and you will almost certainly break the latches that hold the bottom plate in place.

Fue útil esta respuesta?

Calificación 2


This works like a charm.


Agregar un comentario

I have the same problem. Did you figure out the problem?

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

Hallvard estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 8

Últimos 7 Días: 70

Últimos 30 Días: 304

Todo El Tiempo: 5,664