The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

Preguntas 3579 Ver todo

iPhone 5s motion sensor doesn't work

Hello, I succesfully changed my iPhone 5s battery. Everything went ok, I just had a little trouble taking the battery out, but didn't damage anything. I followed the guide backwards and went plugging everything in step by step.

I closed the phone and everthing works just fine. The only thing that doesn't work is the motion sensor. I have noticed that neither the compas or the Health app detect any motion. Plus, when I turn the phone, pictures don't turn as well.

I checked and turn is not blocked and I haven't changed any motion related settings, I'm positive it's a hardware problem.

Thanks a lot in advance.

Contesta esta pregunta Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2
Agregar un comentario

2 Respuestas

Respuesta Más Útil

You can damage the motion chip that is located near the screen connecrors chances are you have damaged it

Fue útil esta respuesta?

Calificación 1

Comentarios:

Hi! Thanks for answering. That was my fear at first, by then I found (link in my comment to the post), that there is one of the screws keeping the screen connectors wich is magnetized. If you place this screw in the slot near the sensor motion (upper right), I will cause the sensor to stop working. I just switched that screw for any other and now is working again. Thanks again!

por

Agregar un comentario

I just experienced the same symptoms: Replaced the battery, and afterwards none of the sensors worked.

After searching more than just the "how to" videos, I found ifixit's step-by-step online guide. I cannot emphasize enough: The four (4) screws securing the RFI shield over the cable connectors are *3* different lengths. The differences are too small to see with the unaided eye. But if you put them in the wrong holes, you can disable the sensors (best case), or damage the logic board (worst case!).

Fortunately, I have a set of micrometers, and was able to measure the screw lengths precisely. After disassembling again, measuring each one, and reassembling with the right screws in the right holes, all sensor functions were restored to normal. Hallelujah!

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

jorgelopezcanales estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 0

Últimos 7 Días: 19

Últimos 30 Días: 53

Todo El Tiempo: 5,440