iMac Intel 27" EMC 2309 (Late 2009, Core 2 Duo 3.06 or 3.33 GHz) ID iMac10,1, EMC 2374 (Late 2009, Core i5 2.66 GHz or Core i7 2.8 GHz) ID iMac11,1

Preguntas 377 Ver todo

iMac screen stay black (logicboard issue?)

Hello,

After having unplugged the iMac, it won't boot and the screen remains black (no start-up sound). The computer was in suspended mode when I disconnect the electric wire.

As I replace the HardDriver (for an SSD which was amazing... till now lol) apple waranty dont works (i've already tried :p).

After some researches i was told that it could be the logicboard and more specificly the bios battery. I replace it (not so easy :s) and now I can hear the start-up sound again... but still the screen remains black :-(

As the logicboard replacement cost 1500$ i don't know what to do... should i throw my all new iMac to the trash ? mdr

Thanks for any response / lead :p

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 2

Comentarios:

I'm willing to hear anything and maybe I wrong... maybe that's not the logicboard, I'm not really sure (while almost though) and any comment would be great !

Thanks

por

Check if the screen show the image even when the light is off. If yes is the problem is in the backlight and in that case you have to change the LED board, which you can buy for something between 50 and 150 dollars. Good luck

por

Agregar un comentario

3 Respuestas

Solución Elegida

Check the diagnostic lights on the motherboard.

LED 1 indicates that trickle voltage from the power supply has been detected. This LED will be ON when the computer is turned off and your power supply is working correctly.

LED 2 indicates that the main logic board has detected proper power from the power supply when the computer is turned on. This LED will be ON when the computer is turned on and the power supply is working correctly.

LED 3 indicates that the computer and the LCD display are communicating. This LED will be ON when the computer is turned on and video signal is being generated.

LED 4 lights only if the computer detects an over-temperature condition. This LED will be OFF when the computer is turned on and running at the correct temperature.

Fue útil esta respuesta?

Calificación 3

Comentarios:

#3 LED on thru me. Trying hooking up to an external monitor to check the graphics chip (GPU) to try to isolate the problem.

por

+ Ralph

por

Same issue here except that LED #2 is flashing slowly (off for 4-5 seconds, on for 2 seconds, repeats... Any ideas?

por

@macintek - since this Q & A are over 6 years old and the answer accepted. please start over fresh with a new question and let's make sure you get the attention you need as your symptoms are different.

por

Agregar un comentario

Thanks a lot for that response !

I've checked the LEDs and when turned off my iMac has only LED1 ON.

When turned on, it has LED1, LED2 and LED3 ON...

Any additionnal clue with thoose datas ?

EDIT: I've tried to start the machine with the flat 27" screen unplugged and... mystery the 3 led's are still ON !

Wasn't the 3rd led supposed to be communication with screen ? I'm confused... any clue would be very very helpfull tranks !

Fue útil esta respuesta?

Calificación 0

Comentarios:

led 3 is on ???

maybe the inverter isn't plugged in or is defective ? is the screen totally black when you start the iMac ? (tried a flashlight ??)

por

@Mayer : External monitor ? How could I do such a thing ? It don't thing it's even possible :s

por

The inverter I don't know but I indeed have run somme issues with the "synchronisation video cable"... Maybe it's juste that cable ? Whatever the screen is full black (even in the dark with a flashlight on it we can't see anything :s). As I said, due to a frien clumsiness when opening the iMac once, there was an "accident". The video connector on the motherboard was damage (I managed to fix it and It worked well for monthes) and the synchronisation cable as well (the connector was ripped, I cut it, softly scratched it and put some hard piece of cardboard and it worked as well). You know everything... any more clues ?

por

Hook up via the mini display port: http://support.apple.com/kb/ht3913

Use a Mini DisplayPort to either VGA or DVI according to the needs of your external display: http://store.apple.com/us/search?find=mi...

por

Yessss... the "trick" is working... When I plug an external monitor !

So what do you think ? Problems with the LED display ? Internal cable issues ?

Thanks a lot for all your responses ;-)

por

Mostrar 1 comentario más

Agregar un comentario

Whin I had this problem i ended up changing out my backlight board and that made the screen go fro pitch black nothing on to blue everything is shiney and working. Not saying that is your problem, butt you can find some on eBay for around $40.

Fue útil esta respuesta?

Calificación 0

Comentarios:

Tdog, great answer. hopefully this got fixed within the last four years since the question was asked:-)

por

The OP was just waiting ;-}

por

Agregar un comentario

Añadir tu respuesta

fpeliss estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 1

Últimos 7 Días: 4

Últimos 30 Días: 27

Todo El Tiempo: 8,743