Other than the Tahoe Limited Edition, the vehicle was redesigned for the 2000 model year on the new GMT800 platform, still shared with the full-sized pickups and SUV's.

Preguntas 19 Ver todo

Location of radio amplifier?

My amp keeps cutting out, shuting off the sound. The radio keeps working.

Contestado! View the answer Yo también tengo este problema

Es esta una buena pregunta?

Calificación 4

Comentarios:

2002 Yukon radio cuts in and out. Every once in a while will radio works Could this be amp.

por

I some help as well mine is doing the same thing

por

I havev2006 yukon xl,i put in a aftermarket radio & now I have no sound but through radio comes on & i dont have no power to my charging outlets,how can I fix this

por

Mine doing same thing you figure it out yet

por

Agregar un comentario

3 Respuestas

Solución Elegida

Rick McAninch, you did not give us a lot of information about which year your Yukon is or which amp. I assume it has the Bose system. Should be inside the center console, just pull the cup holders up to see if it is there.

AMPLIFIER REPLACEMENT

REMOVAL PROCEDURE

1. If equipped with a Bose(TM) amplifier, remove the radio amp fuse located under the hood electrical center.

2. Remove the floor console bezel.

3. Remove the cupholder.

4. Remove the bolts (1) retaining the console to the instrument panel (I/P).

5. Remove the console storage bin.

6. Remove the center console end panel.

7. Disconnect the audio amplifier electrical connectors.

8. Remove the 4 screws retaining the upper console bracket to the lower console bracket.

9. Move both front seats to the fully forward.

10. Reposition the inboard seat track trim (1) in order to gain access to the rear console side panel screw (2).

11. Remove both rear console side panel screws

12. Move both front seats to the fully rearward.

13. Remove both front console side panel screws (1).

14. Disconnect the floor console electrical connector.

15. Remove the console assembly from the vehicle.

16. Remove the audio amplifier screws (1).

17. Remove the audio amplifier from the vehicle.

Hope this helps, good luck.

Fue útil esta respuesta?

Calificación 3

Comentarios:

How do

I tell if it's the radio or amp.

por

Agregar un comentario

Is the antenna plugged in?

Update (10/24/2017)

I have a 1999 yukon denali with RPO code Y91... I completely removed it cause I think they are crap. And installed after market amp HU and speakers including sub of course. But if the radio is not working.. make sure antenna is plugged in or if you have a powered antenna make sure that remote turn on wire is hooked up.

Fue útil esta respuesta?

Calificación 1
Agregar un comentario

I have a 2005 Chevy Silverado 1500 LS Z71. I installed this unit ( http://www.ebay.com/itm/Car-DVD-CD-Playe...) and everything works except the radio looks just like the screen shown in the video, but no sound and it will not allow me to change the stations... I get sound from the DVD, NAV, BT, but the radio goes blank, no sound and stations will not change using the touch screen nor does it work using the tuner knob.

Fue útil esta respuesta?

Calificación 0
Agregar un comentario

Añadir tu respuesta

Rick McAninch estará eternamente agradecido.
Ver Estadísticas:

Ultimas 24 Horas: 61

Últimos 7 Días: 353

Últimos 30 Días: 1,584

Todo El Tiempo: 27,520